ข่าวไอที Blognone » ทดสอบกันดีๆ แพตช์ Meltdown/Spectre บนวินโดวส์มีปัญหากับซอฟต์แวร์ความปลอดภัย เครื่องเอเอ็มดีบางเครื่องบูตไม่ขึ้น

ทดสอบกันดีๆ แพตช์ Meltdown/Spectre บนวินโดวส์มีปัญหากับซอฟต์แวร์ความปลอดภัย เครื่องเอเอ็มดีบางเครื่องบูตไม่ขึ้น

8 มกราคม 2018
33   0

ไมโครซอฟท์ออกแพตช์ Meltdown/Spectre มาตั้งแต่วันที่ 3 มกราคมที่ผ่านมา เนื่องจากเป็นแพตช์ที่แก้ไขการทำงานเคอร์เนล ทำให้มีปัญหากับซอฟต์แวร์ป้องกันไวรัสบางตัวโดยไมโครซอฟท์รับรู้ปัญหานี้ตั้งแต่ระหว่างทดสอบแพตช์

ทางแก้คือไมโครซอฟต์กำหนดให้เครื่องที่จะได้รับแพตช์วันที่ 3 มกราคม ต้องตั้งค่าในรีจิสตรี SOFTWARE\Microsoft\Windows\CurrentVersion\QualityCompat เอาไว้ล่วงหน้า ไม่เช่นนั้นจะไม่ได้รับแพตช์ หากติดตั้งซอฟต์แวร์ป้องกันไวรัสเอาไว้ แม้จะเป็นของฟรีเช่น Microsoft Security Essentials เมื่ออัพเดตซอฟต์แวร์ที่รองรับแพตช์ใหม่เรียบร้อยแล้ว ตัวป้องกันไวรัสก็จะเขียนรีจิสตรีนี้ให้เอง แต่หากไม่ได้ติดตั้งตัวป้องกันไวรัสใดๆ เลยจะต้องตั้งค่ารีจิสตรีนี้ด้วยตัวเอง

นอกจากตัวป้องกันไวรัสแล้ว ตอนนี้ก็มีซอฟต์แวร์ความปลอดภัยที่ทำงานกับเคอร์เนลในระดับต่ำมีปัญหาหลายตัว เช่น PulseSecure VPN และ Sandboxie จาก Sophos ที่ออกรุ่น 5.23.3 ในวันที่ 5 ที่ผ่านมาเพื่อแก้ปัญหาไม่ทำงานเมื่อติดตั้งแพตช์ KB4056897 (Windows 7 SP1)

ปัญหาที่หนักที่สุดคงเป็นเครื่องที่ใช้ซีพียูเอเอ็มดีบางเครื่อง ถึงกับบูตไม่ขึ้นไปเลยเมื่อติดตั้งแพตช์ KB4056892 (Windows 10 1709) โดยผู้ใช้ที่แจ้งปัญหาระบุว่าใช้ซีพียู AMD Athlon 64 X2 หรือ AMD Sempron

ใครดูแลระบบในองค์กรขนาดใหญ่แล้วจะรีบอัพเดตป้องกัน Meltdown/Spectre คงต้องหาเครื่องทดสอบกันสักหน่อยก่อนปล่อยแพตช์ครับ

ที่มา - The Register

[source: https://www.blognone.com/node/98886]