ข่าวไอที Blognone » แอปที่ตั้ง Target API เวอร์ชัน 16 ลงไปอาจไม่สามารถรันบน Android P ได้

แอปที่ตั้ง Target API เวอร์ชัน 16 ลงไปอาจไม่สามารถรันบน Android P ได้

19 มีนาคม 2018
31   0

ที่ผ่านมาเราเห็นแอปเปิลที่บีบให้นักพัฒนาปรับปรุงแอปให้รองรับ iOS เวอร์ชันใหม่อยู่เสมอ ไม่ว่าจะด้วยเหตุผลด้านความปลอดภัยหรือประสิทธิภาพก็ตาม ขณะที่กูเกิลเองก็เริ่มเห็นท่าทีนี้หลังการกำหนด Target API ขั้นต่ำสำหรับแอปบน Play Store ต้องรองรับ Android Oreo ขึ้นไปเมื่อปลายปีที่แล้ว

ซึ่งในการประกาศคราวนั้นกูเกิลระบุว่า ในแอนดรอยด์รุ่นใหม่ๆ (ไม่ได้ระบุชัดว่า P หรือ Q) จะไม่อนุญาตให้รันแอปที่ตั้ง Target API เก่าเกินไป ด้วยเหตุผลด้านความปลอดภัยและประสิทธิภาพในการทำงาน ล่าสุดดูเหมือนว่านโยบายนี้จะเริ่มใช้แล้วในแอนดรอยด์ P ที่มีการกำหนด Target API ขั้นต่ำของแอปคือเวอร์ชัน 17 หรือแอนดรอยด์ 4.2

บนเอกสาร Android P Developer Preview ทางกูเกิลระบุชัดเจนว่าแอปจะไม่สามารถติดตั้งและรันได้ อย่างไรก็ตามเมื่อลองติดตั้งแอปที่เก่ากว่าแอนดรอยด์ 4.2 ลงบนแอนดรอยด์ P ตัวแอปกลับสามารถรันได้แต่ขึ้นคำเตือนว่า "แอปถูกพัฒนาขึ้นสำหรับแอนดรอยด์เวอร์ชันเก่าและอาจทำงานไม่ราบรื่น" ซึ่งก็ต้องรอคำยืนยันจากกูเกิลอีกครั้งว่าเมื่อแอนดรอยด์ P ตัวจริงออกแล้ว แอปจะไม่สามารถรันได้หรือกูเกิลจะขึ้นแค่คำเตือนเช่นนี้เอาไว้เหมือนเดิม

ที่มา - Android Police

alt="Android P"

[source: https://www.blognone.com/node/100810]